O que 232 significa no padrão RS232?


32

"RS" nos padrões de comunicação RS232 e RS485 significa "Padrão Recomendado". Mas que informação "232" ou "422" ou "485" transmitem no nome? Que convenção de nomenclatura é usada para números que sucedem as letras "RS" ao nomear os padrões RS?

Respostas:


27

É o número de série do documento do padrão. O mesmo motivo pelo qual o protocolo HTTP também é conhecido como RFC2616 e a linguagem de programação Javascript também é conhecida como ECMA262.

Os números em si não têm significado. Por exemplo, enquanto o EIA232 especifica as características elétricas de um sistema de comunicação serial digital, o EIA222 especifica padrões para mastros de antena e o RS225 é um padrão para conectores de RF.

A Wikipedia possui uma lista incompleta de padrões populares de RS / EIA: https://en.wikipedia.org/wiki/EIA_standards


3
Os números da RFC ocasionalmente têm uma pequena estrutura, mas, até onde eu sei, é limitado a reutilizar os dois ou três dígitos anteriores para atualizar um padrão importante (por exemplo, a RFC 822, a especificação principal de email original, foi substituída pela RFC 2822 e depois pela RFC 5322).
— Zwol 01/02

3
Não conheço ninguém que se refira ao protocolo HTTP como RFC2616 - o próprio documento atribui um nome ao protocolo, então esse é o seu nome. (Ele nem é mais especificado pela RFC 2616 - foi substituído pelas RFCs 7230 a 7237 em 2014).
— Henning Makholm

3
@ HenningMakholm - provavelmente é exatamente porque o IETF não mantém números de documentos para um tópico específico que não usamos o número do documento em nome de protocolos. Outros organismos de normas geralmente usam um esquema de versão (por exemplo, anexando uma data após o número do documento, como no exemplo de Crowley da ISO9001: 2016 referente a uma versão específica da ISO9001) que permite que o número base permaneça o mesmo quando novas versões de uma norma são lançadas . Isso torna muito mais conveniente usar o número do documento para se referir ao padrão.
— Periata Breatta

@Periata Breatta Obrigado. Explicação razoável.
— Sonam Khullar 02/02

38

Não significa nada; faz parte de uma lista seqüencial de padrões EIA : -

insira a descrição da imagem aqui


Bem, refere-se a um item muito específico nessa lista. Isso não é significativo?
— Octopus

@ Octopus talvez você possa ser um pouco mais claro sobre o que você quer dizer?
— Andy aka

Você disse "isso não significa nada". Significa em que parágrafo ou seção é abrangida.
— Octopus

@ Octopus talvez, se você se tornasse mais pedante em sua atitude em relação a aceitar formalmente respostas para algumas das perguntas que você levantou, eu ficaria um pouco impressionado com seu humor cortante.
— Andy aka

Eu chamei você apenas de afirmação porque está sugerindo que o OP fez uma pergunta inválida. "O que isso significa?", "Nada!" Na verdade, é uma excelente pergunta. Você não está impressionando ninguém. Se o seu trabalho aqui é invalidar perguntas e comentários, então está bem feito.
— Octopus

3

RS = padrão recomendado

RFC = solicitação de comentário,

números não têm nenhum significado real


1
O OP já conhece o RS e não menciona a RFC.
— JDługosz 02/02

1
Historicamente, RS = Setor de Rádio. Este era o sub-departamento do EIA envolvido no padrão. Foi adaptado ao padrão recomendado ao longo do tempo.
— 1.01 de
Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.