definir registro do Google Apps SPF no Amazon AWS Route 53


13

Estou usando a nova GUI da AWS para o Route 53 para configurar meus registros de domínio. No entanto, o console da AWS não aceita o registro recomendado do Google Apps SPF v=spf1 include:_spf.google.com ~all(encontrado aqui ).

Ele continua me dando um erro informando

The record set could not be saved because:
- The Value field contains invalid characters or is in an invalid format.

Isso acontece ao salvar como SPF e TXT. Alguma ideia?


Você tem que citar, o que também me assustou. As instruções do Google são terríveis , e é por isso que escrevi um guia completo sobre isso: blog.andrewray.me/…
— Andy Ray

Respostas:


31

Eu tive que colocar meu registro SPF entre aspas para que ele funcionasse.

"v=spf1 include:_spf.google.com ~all"



1

Minha correção foi agrupar o registro entre aspas e substituir o ~ por um -.

Aqui está o valor que funciona:

"v = spf1 incluem: _spf.google.com -todos"


2
De acordo com support.google.com/a/answer/178723?hl=en, você deve usar ~ all not-all no Google Apps.
— 21815 Sean Bannister

1
A única razão pela qual substituí o ~ por - foi fazer com que a rota 53 a aceitasse, mas, para minha surpresa, ela também foi aceita pelo Google Apps como válida.
— Jacques Snyman

-1

Usando o dobro, você pode definir esse valor sem gerar mensagens de erro. Funcionou bem para mim.


Para esclarecer, ele quis dizer "" aspas duplas "", que ignora as verificações de caracteres inválidos.
— 23719 Justin
Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.