Como configurar o Amazon Route53 trabalhando sem www no subdomínio


13

edit: Amazon agora suporta isso. http://aws.typepad.com/aws/2012/12/root-domain-website-hosting-for-amazon-s3.html

Tenho minha configuração de domínio no Route53 no Amazon AWS

comando exec ping no meu domínio sem www

$ ping mydomain.com.br
ping: cannot resolve domain.com.br: Unknown host

comando exec ping no meu domínio com www

$ ping www.domain.com.br
PING s3-website-sa-east-1.amazonaws.com (177.72.245.6): 56 data bytes
64 bytes from 177.72.245.6: icmp_seq=0 ttl=244 time=25.027 ms
64 bytes from 177.72.245.6: icmp_seq=1 ttl=244 time=25.238 ms
64 bytes from 177.72.245.6: icmp_seq=2 ttl=244 time=25.024 ms

Rota 53 -> Criar conjunto de registros -> Nome: [] .domain.com.br Defina o valor CNAME: www.domain.com.br

ERRO DE EXIBIÇÃO

"O RRSet do tipo CNAME com nome DNS mydomin.com não é permitido no ápice na zona mydomin.com"


1
Olá, observe que as respostas devem ser fornecidas na seção Respostas abaixo, NÃO como edições da pergunta.
— Michael Hampton

Respostas:


6

Você não pode usar um CNAME para o domínio no nível raiz, ele viola os RFCs e pode causar vários problemas. Infelizmente, a Amazon não tem uma solução alternativa para sites hospedados no S3.

edit: Amazon agora suporta isso. http://aws.typepad.com/aws/2012/12/root-domain-website-hosting-for-amazon-s3.html

Existem serviços como o WWWizer que você pode usar para redirecionar para o WWW, mas eles não são uma solução perfeita.


2
Você PODE usar CNAME's com domínios no nível raiz, não violando o RFC. O problema é que CNAME não pode coexistir com outros registros, por exemplo, MX. De RFC1034 ...... Se um RR CNAME estiver presente em um nó, nenhum outro dado deverá estar presente; isso garante que os dados para um nome canônico e seus aliases não possam ser diferentes. Essa regra também garante que um CNAME em cache possa ser usado sem verificar com um servidor autoritativo outros tipos de RR.
— James Park-Watt

@ JamesPark-Watt blog.cloudflare.com/… "O problema é que a RFC do DNS (RFC1033) exige que o" ápice da zona "(às vezes chamado de" domínio raiz "ou" domínio nu ") seja um" Um Registro ", não um CNAME ".
— precisa

Perfect -> ligação Root site de hospedagem de domínio para o Amazon S3
— romuloigor

1
Os CNAMEs da Apex não são legais. Foi explicitamente explicitado no RFC2181 por um tempo agora.
— Andrew B

5

Crie um conjunto de registros de recursos (endereço A - IPv4) que "tenha o mesmo nome que a zona hospedada, deixando o campo Nome em branco".

Amazon Route 53 - Editar conjunto de registros

Este é o aviso que o Route 53 dá ao tentar adicionar o nome "@", que eu também era personalizado para os servidores de nomes Bind. Portanto, não use '@', use um nome vazio ''.


1
E agora, usando as @obras do registro A para obter um domínio nu.
— Rubens Mariuzzo 30/03

1

Se você deseja apontar seu domínio raiz mydomain.com.br para o serviço da AWS:

  • crie um registro do tipo A - Endereço IPv4 .
  • depois selecione Sim para Alias.
  • O Alias ​​Target listará o preenchimento automático para seus recursos da AWS.
Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.