Por que o IPv6 usa AAAA para representar seus registros DNS?


22

Existe uma razão para que o padrão IPv6 use AAAA em vez de AA? Não consigo encontrar referência aos registros AA ou AAA no DNS. As como indicam algo específico?


5
É improvável que você obtenha uma resposta autorizada para isso, como foi decidido há quase um quarto de século; a resposta, se existir, provavelmente estava em uma lista de correspondência morta há muito tempo, para a qual os arcos desapareceram da Internet há muitos anos.
— Michael Hampton

7
@MichaelHampton AAAA é definido pelo RFC1886 e depois pelo RFC3596. O primeiro foi draft-ietf-ipngwg-dnse o segundo, draft-ietf-dnsext-rfc1886bispara que você possa ir aos grupos de trabalho. O primeiro não tem mais arquivos de listas de discussão, mas através dos segundos você pode encontrar tópicos interessantes, como: mailarchive.ietf.org/arch/msg/dnsext/… ou esse ID: tools.ietf.org/html/draft- IETF-DNSEXT-aaaa-a6-01 ou mailarchive.ietf.org/arch/msg/dnsext/...
— Patrick Mevzek

@PatrickMevzek Todos esses tópicos da lista de discussão e o ID parecem ser AAAA em comparação com o A6, algo que aconteceu muitos anos após os eventos que o OP está perguntando. Há algo específico que você deseja chamar atenção?
— Michael Hampton

4
@MichaelHampton Apenas o fato de que nem tudo está perdido, um pouco de pesquisa não fornecer algumas informações úteis ... e AAAA vs A6 também dá explicações sobre o porquê AAAA ...
— Patrick Mevzek

Respostas:


50

Entendo que esta é uma pergunta especificamente sobre o nome do tipo RR?

Obviamente, poderia ter um nome diferente, o nome AAAAdos registros de endereço IPv6 refere-se a um endereço IPv6 (128 bits), sendo quatro vezes o tamanho de um endereço IPv4 (32 bits).


10
Para um pouco de histórico extra: havia também um tipo A6 que podia fazer referências hierárquicas em que parte do endereço era definida em outro registro A6 etc. Foi preterida devido à complexidade adicionada.
— Sander Steffann 21/03/19

Oh, as juntas horríveis! Sim, os primeiros rascunhos continham algumas coisas (tecnicamente impressionantes). E tenho certeza de que você está certo quanto ao tamanho ser a chave; Acho que não consigo me lembrar de onde li. Você poderia tentar pedir os sobreviventes cedo na Internet as pessoas, por exemplo, Gene Spafford está no Quora ...
— Will Crawford

11
@WillCrawford Eu não sou tão veterano, mas me lembro de ter aprendido que essa foi a razão por volta de 2000, então não é uma nova explicação. E tem a combinação certa de bobagem e obviedade como justificativa original.
— hobbs

11
… O IPng foi recomendado em 1994 , publicado como RFC 1752 em 1995 .
— Will Crawford

4
"A sintaxe do registro de recurso AAAA é exatamente a mesma do registro A, exceto que os endereços demoram mais para digitar" - ; login: the magazine of usenix & sage (pdf)
— Will Crawford

0

A RFC 1035, que define registros de recursos para o DNS, menciona o significado do tipo de registro A como 'endereço do host'. O "endereço do host" naquela época era de 32 bits.

O RFC 3596 explica o novo registro de recurso para IPv6. Ele define um novo tipo de registro a ser usado para armazenar um endereço IPv6.

Portanto, o novo tipo de registro deve significar o endereço armazenado com ele. A melhor maneira de fazer isso é comparar o IPv6 com o IPv4 e, portanto, temos quatro A's - quatro vezes o comprimento do IPv4.

Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.