Caixa de ferramentas do Docker: Erro ao criar a máquina: Erro no driver durante a criação da máquina: Número máximo de tentativas (5) excedidas


9

Estou no Windows 7, VirtualBox 5.0.4, Docker toolbox 1.9.0. Quando executo o início rápido, recebo:

Creating Machine default...
Running pre-create checks...
Creating machine...
Error creating machine: Error in driver during machine creation: Maximum number of retries (5) exceeded
Looks like something went wrong... Press any key to continue...

Mas eu recebo uma VM 'padrão' em execução quando abro o VirtualBox e dou uma olhada. No meu VBox.log eu vejo (o arquivo completo está aqui ):

00:00:00.696246 HM: HMR3Init: VT-x w/ nested paging and unrestricted guest execution hw support

Talvez o suporte ao VT-X seja bom para mim. Logo no final do arquivo de log, vejo algo ameaçador sobre o D-Bus não estar instalado:

00:00:46.950561 VMMDev: Guest Log: 00:00:10.018836 vminfo   Error: Unable to connect to system D-Bus (3/3): D-Bus not installed

O problema do D-Bus foi relatado aqui https://github.com/docker/toolbox/issues/214 Quando executo o início rápido novamente diretamente após isso, recebo uma mensagem de erro sobre como obter um endereço IP:

Machine default already exists in VirtualBox.
Setting environment variables for machine default...
Error running connection boilerplate: Error getting driver URL: Something went wrong running an SSH command!
command : ip addr show dev eth1
err     : exit status 255
output  :


                    ##         .
              ## ## ##        ==
           ## ## ## ## ##    ===
       /"""""""""""""""""\___/ ===
  ~~~ {~~ ~~~~ ~~~ ~~~~ ~~~ ~ /  ===- ~~~
       \______ o           __/
         \    \         __/
          \____\_______/

Error getting IP address: Something went wrong running an SSH command!
command : ip addr show dev eth1
err     : exit status 255
output  :
docker is configured to use the default machine with IP
For help getting started, check out the docs at https://docs.docker.com
NOTE: When using interactive commands, prepend winpty. Examples: 'winpty     docker run -it ...', 'winpty docker exec -it ...'.

E se eu executar um comando, recebo outra mensagem relacionada à conexão:

$ winpty docker run hello-world
An error occurred trying to connect: Post     http://localhost:2375/v1.21/containers
/create: dial tcp 127.0.0.1:2375: ConnectEx tcp: No connection could be made     because the target machine actively refused it.

Nesse ponto, fui para https://www.virtualbox.org/wiki/Testbuilds e obtive o VirtualBox 5.0.9, depois desinstalei o Docker Toolboox, excluí a VM padrão e o diretório .docker, reinstalei a caixa de ferramentas e reinstalei a caixa de ferramentas. execute-o e tenha o mesmo problema:

Creating Machine default...
Creating CA: C:\Users\marwick\.docker\machine\certs\ca.pem
Creating client certificate: C:\Users\marwick\.docker\machine\certs\cert.pem
Running pre-create checks...
Creating machine...
Error creating machine: Error in driver during machine creation: Maximum number of retries (5) exceeded
Looks like something went wrong... Press any key to continue...

O arquivo de log para esta tentativa está aqui: http://pastebin.com/9VjD9t6P

Como posso fazer isso funcionar?

Respostas:


12

Teve o mesmo problema (a execução de comandos do docker fornece uma mensagem de erro: Nenhuma conexão pôde ser estabelecida porque a máquina de destino a recusou ativamente).
Há problemas com permissões (provavelmente a máquina de destino foi criada em uma conta de usuário diferente).

Isso funcionou para mim: abra o Oracle VM VirtualBox e clique com o botão direito do mouse na máquina denominada 'padrão'. Se estiver em execução, selecione "Fechar -> Desligar". Em seguida, selecione "Remover ..." e clique no botão "Excluir todos os arquivos".

feche o Oracle VM VirtualBox e execute o Docker_Quickstart novamente. Ele criará uma nova VM padrão sem problemas de permissão.


Esta solução funcionou para mim também.
— Oliver Burdekin

Fico feliz que esteja funcionando para outras pessoas, mas já fiz isso várias vezes e excluindo os arquivos de ponto associados à VM, e não há melhorias.
— Ben

@ Ben você deve excluir arquivos de UI VirtualBox (apagar todos os arquivos)
— MediaVince

0

Ben, talvez você use o sistema fantasma, então o uxtheme.dll foi quebrado, levando à sua falha no início da VM. Use o uxtheme.dll original para substituir c: \ windows \ system32 \ uxtheme.dll e, em seguida, ele criará uma nova VM padrão sem problemas de permissão.


Você pode explicar o que você quer dizer com 'sistema fantasma'? Eu não entendo: $
— Ben

@ Ben, eu acho que ele quer dizer que seu sistema operacional foi clonado de outro disco rígido.
— Bhoomtawath Plinsut
Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.