O nome> org.freedesktop.PolicyKit1 não foi fornecido por nenhum arquivo .service


82

Ao tentar iniciar a system-config-userspartir da linha de comando, recebo o seguinte aviso e a ferramenta não abre. Estou usando o CentOS 7 com o Mate 1.8.1.

AVISO **: Erro ao enumerar ações: GDBus.Error: org.freedesktop.DBus.Error.ServiceUnknown: O nome org.freedesktop.PolicyKit1 não foi fornecido por nenhum arquivo .service

Erro ao verificar a autorização org.freedesktop.policykit.exec: GDBus.Error: org.freedesktop.DBus.Error.ServiceUnknown: O nome org.freedesktop.PolicyKit1 não foi fornecido por nenhum arquivo .service

yum list polkit *

Installed Packages
polkit.x86_64   0.112-5.el7 @anaconda
polkit-devel.x86_64 0.112-5.el7 @base    
polkit-docs.noarch 0.112-5.el7 @base    
polkit-gnome.x86_64 0.105-6.el7 @epel    
polkit-pkla-compat.x86_64 0.1-4.el7  @anaconda

O que está faltando no meu sistema para causar esse erro?


Você está usando o XFCE?
— precisa saber é o seguinte

Estou usando o Mate 1.8.1
— um codificador

Como não sei dizer quais serviços estão sendo enumerados, não posso dizer qual pacote instalar. O erro não é causado pelo kit de políticas, mas por um dos serviços que o kit de políticas está tentando carregar. XFCE tem esse problema comudisks
— eyoung100

Existe uma maneira de monitorar quais serviços o kit de políticas está usando ou tentando usar?
— um codificador

Não que eu saiba. Os sistemas pré-sistema usam o policykit / consolekit em conjunto com o Dbus para impor permissões de login. Isso leva a duas possibilidades. 1. O usuário no qual você efetuou login não é membro some groupe some grouptem permissão para acessar o serviço ausente. 2. Um dos serviços monitorados por system-config-usersnão está instalado. Como um palpite, procure em seu repo pacote paramate-polkit
— eyoung100

Respostas:


145

Acabei de ter o mesmo retorno ao instalar o deluged no arch, digitei:

 systemctl start deluged

Eu tentei com sudo e funcionou bem. Parece ser um problema de permissão de grupo.

Tudo o que fiz foi ativar as permissões para minha conta de usuário e digitar:

 sudo systemctl start deluged

funcionou como um encanto.


10
Mensagem realmente estranha, diferente do * nix. Nunca teria pensado que esta seria a solução! Obrigado!
— Sufian

11
Ah, claro, claro sudo. Seria realmente útil se eles tivessem um sistema que retornasse um erro como "privilégios de root necessários" ou algo um pouco mais óbvio.
— Mint

20
Possivelmente o erro mais contra-intuitivo de todos os tempos.
— ffledgling

2
Provavelmente, está reclamando que você não possui o Polkit configurado, o que seria necessário para permitir o systemctl não-usuário sem privilégios de root. Apenas um palpite
— Duncan X Simpson -

Trabalhou para mim também, thx
— Ivan Marjanovic

57

Para esclarecer e resumir a postagem do SNP22 : Você provavelmente acabou de se esquecer sudo.

sudo systemctl [...]

Aviso absolutamente enganoso ...


1
Provavelmente se juntar à lista de mensagem de erro mau relata github.com/systemd/systemd/labels/needs-better-log-message mas eu preciso testá-lo com a versão mais recente em primeiro lugar ...
— Ben Creasy

ESTA!! quando você tenta fazer um systemctl daemon-reloadsem raiz, ele relatará um erro estranho como este. Basta verificar se ele está faltando o sudoou executar no usuário correto ou você permitiu a rootexecução (em ansible a become: true)
— higuita
Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.