Falha na etapa EXEC spawning / bin / plymouth (teste Debian)


16

Depois de executar uma dist-upgradeinstância em um teste Debian (Jessie), não consigo mais inicializar. Estou abandonado no prompt de comando:

Welcome to emergency mode! After logging in, type "journalctl -xb" to view system logs

O seguinte erro aparece:

root@debian:~# journalctl -xb
debian systemd[222]: Failed at step EXEC spawning /bin/plymouth: No such file or directory

Surpreendentemente, o Google não está ajudando e o pequeno fio que vejo são para o Arch (mesmo se eu adicionar + debian na minha pesquisa) e não faz sentido para mim.

Algum ponteiro sobre como se recuperar disso?

# uname -a
Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.7-2 (2014-11-06) x84_64 GNU/Linux

Talvez isso precise ser alterado para remover o teste do cabeçalho, pois está "confirmado" no Jessie / stable, etc. desde o SystemD; (
— Hvisage

Respostas:


20

Eu também tive esse erro preciso hoje como resultado de uma atualização do debian wheezy para jessie.

O sistema falhou ao reiniciar, apesar de nenhum erro do "apt-get dist-upgrade". O resultado final do erro via "journalctl -xb" (ou "-xd") foi associado ao "plymouth" (um aplicativo que eu nunca tinha ouvido falar). Mas a falha na reinicialização não teve nada a ver com plymouth, mas uma pequena anomalia em uma entrada auxiliar em / etc / fstab: altere "auto" para "noauto" para um dispositivo de cdrom (nada a ver com NFS) e, em seguida, O systemd permitirá a inicialização. Esta é uma linha fstab que funcionava sob chiado e falha silenciosamente para permitir uma reinicialização sob jessie.

Não houve erro via journalctl associado ao fstab. Foram pesquisas de sorte na web que me levaram a essa solução obscura.


4
Corrigir. O erro de plymouth chamou minha atenção e eu negligenciei a causa real.
— youri

Sim, no meu caso, já era Noauto, mas um sistema de arquivos que não estava "lá" por causa do disco extra adicionado ... <adding-French-choice-words> systemd que absolutamente teve que sugar a montagem do sistemas de arquivos ... na verdade, deve ser um relatório de erro do systemd ... mas, conhecendo o LP de experiências anteriores sobre a montagem do sistema de arquivos, ele será ignorado; (o melhor em resolver problemas relacionados ao systemd no futuro
— Hvisage

Em vez de comentar a linha no fstab, adicione a nofailopção para todos os sistemas de arquivos não essenciais. Esta opção instrui o systemd a ignorar erros durante a montagem e a continuar o processo de inicialização normal.
— Marki555,

11

Combinando as respostas anteriores, esse problema parece ser causado por entradas inválidas no / etc / fstab.

No meu caso, estou executando dentro do virtualbox e era uma pasta compartilhada que eu havia configurado para montar automaticamente na inicialização, o que era o problema. Nas outras duas respostas, foram os sorteios para o dispositivo NFS ou CD-ROM.

Eu sugeriria que, para solucionar problemas, apenas comente todas as linhas não essenciais no / etc / fstab e, em seguida, adicione-as uma a uma até que você replique o problema.

A linha problemática pode então ser diagnosticada e corrigida. É possível durante a atualização dist que coisas como pastas compartilhadas do Vbox, compartilhamentos de rede ou outros sistemas de arquivos especializados não tenham sido atualizados corretamente.


SIM!!!!! veja meu comentário em outra resposta
— Hvisage

3

Eu tive o erro exato hoje.

Eu instalei o plymouth, mas não mudou o resultado.

Foi causado por uma entrada nfs incorreta no / etc / fstab. Após excluir essa entrada, o erro desapareceu. Eu acho que esse comportamento horrível é devido ao sistema estúpido.


2

Confirmo que é um problema no fstab. Se você entrar no fstab e excluir a última linha, você criou tudo como antes e o sistema será iniciado. Eu tenho um problema de montagem automática no compartilhamento no VirtualBox 5 / debian 8. Não há problema no Virtualbox 4 / debian 7


0

Vejo que este é um tópico bastante antigo neste momento ... mas também tive esse problema hoje.

Eu tive que comentar esta linha /etc/fstabpara impedir que o sistema inicialize no 'modo de emergência':

#UUID=0x0000x0-0x00-0000-xx00-0000xxx00000 /boot           ext2    defaults        0       2
/dev/mapper/Ubuntu16043LTSVM--vg-swap_1 none            swap    sw              0       0

* (UUID é ofuscado intencionalmente)

ATUALIZAR:

A linha UUID /etc/fstabparece estar com falha nesse problema. Ímpar. Depois de ler mais sobre esse problema neste tópico, eu ainda não estava mais perto de uma resposta definitiva sobre a causa raiz, mas pelo menos o SWAP está configurado agora.

Alguém foi capaz de resolver esse problema completamente? ou encontrar a causa raiz?

Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.