Centos 7: falha ao ativar / desativar a rede: configurar a interface para uma interface de tronco


9

O switch configurado no servidor (Centos 7) está configurado como tronco para a VLAN # 115,2014. Eu carreguei

# lsmod | grep 8021q
# modprobe 8021q

Gostaria de configurar um endereço IP no servidor usando a VLAN # 115 Executando a seguinte configuração:

ifcfg-em1

TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=em1
UUID=c0c4d851-d762-4301-8c20-d6128aee5261
DEVICE=em1
ONBOOT=yes

ifcfg-em1.115

TYPE=Ethernet
BOOTPROTO=none
IPADDR=172.31.141.242
PREFIX=24
GATEWAY=172.31.141.1
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=em1.115
UUID=c0c4d851-d762-4301-8c20-d6128aee5261
DEVICE=em1.115
VLAN=yes
ONBOOT=yes

Acabei não conseguindo reiniciar o serviço de rede. A mensagem de erro exibida é:

Failed to start LSB: Bring up/down networking.

O que estou fazendo de errado?

Respostas:


23

parece que a desativação do NetworkManager fez o truque :)

systemctl stop NetworkManager
systemctl disable NetworkManager

1
Reiniciar funcionou para mim (não tentei restart, mas usei em startvez de disable).
— Skippy le Grand Gourou

1
Você faz meu dia! minhas configurações de VLAN e ligação não puderam ser iniciadas após a atualização do servidor e tudo por causa do NetworkManager.
— Fusor

2
@iamsterdam ele trabalhou para mim, mas você poderia por favor, descreva por que ela funciona depois de desactivarNetworkManager
— Vishrant

1
eis foi incrível ...
— Muthukumar Anbalagan

8

Talvez um pouco tarde, mas o problema no meu caso era que o campo UUID das duas interfaces era o mesmo e elas deveriam ser únicas. Desabilitar o NetworkManager faz o truque, mas a solução real seria alterar / excluir o campo. Deixando isso aqui para referência futura.


2

Eu estava enfrentando o mesmo problema. Felizmente,

/etc/rc.d/init.d/network stop

graciosamente parou o serviço de rede. Então eu fiz um:

ip addr flush dev <<dev-name>>

Depois disso, você pode iniciar o serviço usando systemctlou /etc/rc.d/init.d/network start.


1
IPV4_FAILURE_FATAL=no
IPV6INIT=yes"

Alterne o valor

IPV4_FAILURE_FATAL=yes
IPV6INIT=no # (if IPV6 not require)

1

reiniciar minha máquina e serviço de rede não foram resolvidos esse problema na minha caixa linux.

Eu removi o arquivo /etc/sysconfig/network-scripts/ifcfg-eth0e, em seguida, recriei o arquivo com um nome diferente, ifcfg-eth1com detalhes de IP estáticos. Depois disso, iniciei o serviço de rede e funcionou.


1

Eu tive esse erro depois de importar uma VM. A solução é corrigir o endereço HW no arquivo / etc / sysconfig / network-scripts / ifcfg-ens32 (ens32 passou a ser minha interface. Você pode verificar o seu usando o Network Manager com nmtui).

Digite 'ip addr' e anote o HW addr da sua interface, por exemplo, 00: 50: 56: 8d: 6a: 9e. Procure a interface na qual você está interessado na lista obtida em 'ip addr'.

Abra para editar seu / etc / sysconfig / network-scripts / ifcfg-ens32 (altere ifcfg-ens32 com o nome da interface, conforme dito acima, obtenha-o do nmtui) e modifique esse endereço ao lado da chave HWADDR.

Agora: reiniciar a rede de serviço


0

você precisa adicionar o seguinte no arquivo HWADDR = "xx: xx: xx: xx: xx: xx" em que xxxx é o endereço mac real ou clonado da sua placa de interface, você pode encontrar pressionando o comando ifconfig -a.


0

Remova qualquer ifcfg-Wiredconnection1 ou -2 adicional dos novos adaptadores adicionados no servidor que não são usados ​​pela rede l2 ou l3 e reinicie. Vai funcionar.


0

Isto resolverá o problema!

# rm /etc/udev/rules.d/70-persistent-ipoib.rules 

# reboot
  • Agora edite / etc / sysconfig / network-scripts / ifcfg-eth0,
  • Adicione um novo HWADDR gerado ou remova-o
  • Remover linha UUID

-Reinicie o serviço de rede

 #systemctl restart network.service

AGORA! Trabalhando.


0
  1. Basta comentar #UUID

    ##UUID=XXXXX-XXXX-XXX-XXXXX
    
  2. Reiniciar rede

    sudo systemctl restart network
    

0

Eu tive o mesmo problema com o LSB no Centos e o Ubunto no VMware. Eu o resolvi desligar o Wifi no host (máquina real), ligar e reiniciar o convidado.


0

Para mim, era um arquivo de entrada / faltando: /etc/sysconfig/network.

Sem arquivo e gateway:

[root@randomHost ~]# file /etc/sysconfig/network
/etc/sysconfig/network: cannot open (No such file or directory)
[root@randomHost ~]#
[root@randomHost ~]#
[root@randomHost ~]# systemctl status network.service
● network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network; bad; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2019-01-07 10:53:38 UTC; 1 weeks 0 days ago
     Docs: man:systemd-sysv-generator(8)
Jan 07 10:53:38 randomHost systemd[1]: network.service failed.

Após adicionar arquivo e gateway:

[root@randomHost ~]# 
[root@randomHost ~]# echo "GATEWAY=10.XX.XX.XX" >> /etc/sysconfig/network
[root@randomHost ~]# 
[root@randomHost ~]# systemctl status network.service
● network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network; bad; vendor preset: disabled)
   Active: active (exited) since Mon 2019-01-14 12:18:28 UTC; 2s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 329008 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=0/SUCCESS)

-1

Basta parar e desativar o NetworkManager

E mais uma vez, reinicie os serviços, será um trabalho

#systemctl stop NetworkManager
#systemctl disable NetworkManager

#service network restart

Isso não é diferente da resposta aceita (além de estar mal formatada). Sua resposta deve agregar algum valor, como explicar por que desativar o Network Manager corrige o problema e talvez mencione quando faz sentido fazê-lo.
— Anthony Geoghegan

Voto positivo - isso me ajudou, mesmo que a resposta aceita não. Pode ser que eu não tenha lido a pergunta corretamente e apenas tenha percorrido rapidamente as respostas, mas reiniciar o NetworkManager sozinho não pareceu fazer nada. Talvez seja óbvio, mas só porque eu vi isso fez eu penso tente reiniciar networkdepois de pararNetworkManager
— ec2011
Ao utilizar nosso site, você reconhece que leu e compreendeu nossa Política de Cookies e nossa Política de Privacidade.
Licensed under cc by-sa 3.0 with attribution required.